
Maya     (Screen Captures copied from Maya Documentation) 

File Management 
 
File > Set Project Use this option to save to your work to your documents folder or drive 
   * Press button to Create Default Workspace (.mel file) if this is a new folder 
 
File > Project Window View or change the default folder set in the new project space 
   * Open this dialog box and click Accept if this is a new folder 
 
File > Save Scene Choose a name for your scene (the current set of models and animations). 
 
 
Project Folders 
 

Scenes – location where your models and scenes are saved (File > Save Scene As...) 
Templates – put 3D object model files to be imported into the scene here 
Images – When rendering, output image files are stored here 
Source Images – put image map graphic files to be imported into the scene here 
Movies – put movie files to be imported into the scene here 
AutoSave – in case of a crash, auto saved scenes can be found here 
 

Interface Basics 
 
Navigating the View 
 

Navigate the view by using the following to move the default camera attached to the view. 
 

• Rotate View: Alt/Option – Left Mouse Click 
• Pan the View: Alt/Option – Middle Button Click 
• Zoom View: Alt/Option – Right Button Click (or just scroll the mouse wheel) 

 
The Quick Layout and Outliner buttons are just below the Tool Box on the left side of the screen. 

 
 

Quickly tapping the spacebar swaps between the single and multi-pane view. 
In the four-pane view, mouse over the view you want to expand before tapping the spacebar. 

  

Switch the view to a single panel 

Switch the view to orthogonal panels (orthographic views by default) 

Switch the view to two side by side panels 

Open the Outliner 



Interface Layout 
 

 

1. Menu Sets: Change the menus for your current workflow step: model, rig, animation, fx, render. 

2. Main Menu: The menu located at the top of the interface. Changes based on your menu set. 

3. Status Bar: Row of common icons below the main menu. Click vertical bars to expand, collapse. 

5. Icon Shelf: Row of icons used for your current workflow step: model, rig, animation, fx, render. 

6. Workspace Selector: Quickly change all menus, shelf, and panels to match your workflow step. 

7. Sidebar Icons: Fast access to the modeling tools, attribute editor, and channel box panels. 

8. Attribute Editor: Panel used to edit attributes for selected objects and nodes 

Channel Box Editor: Panel used to edit the subset of animatable attributes 

9. Layer Editor: Work with Maya layers 

10. View Panels: Shows your scene’s objects. Includes a View Panel Menu and View Panel Toolbar. 

11. Tool Box: Basic tools for selections and transforms. Also shows the last special tool used. 

12. Quick Layout Buttons: Switch between View Panel layouts 

Outliner Button: Quickly open the Outliner Panel 

13. Time Slider: Shows the current Time Range, current time, keyframes, and a cursor for scrubbing. 

14. Range Slider: Set the start and end frames for the entire animation and the current Time Range. 

15. Playback Controls: Play a preview of your animation inside your currently selected View Panel. 

17. Playback Options: Quick access to frame rate, looping, auto keying and Time Slider preferences. 

  



Menus 
 

Use the Workspace Selector to choose the Maya Classic Workspace. This includes most of the 
icons, menus, and panels you need to do basic Maya work. 
 

 
 
Practice using the Menu Sets dropdown to switch the main menus to Rendering and Animation. 
 

 
 
 
 

 
 
 
 
 
 

Right Click inside a view to open the context 
menu, called the Marking Menu. 

 
Shift – Right Click an object or view will often 
open more specialized marking menus. 

 
 
 
  
 
 Press and hold the spacebar to open a secret 

menu called the Hotbox Menu, which has 
shortcuts to the choices in all the difference 
menu sets. 

  

Many options in the Main Menus have a small square box icon on the right side . Releasing your 
mouse button while hovering over those squares will open the Menu Options dialog box. 



Modeling 
 
Modeling Menu Set 

Many of the menu options used for modeling are only available when the 
Modeling Menu Set is chosen. If any of the features below seem unavailable, 
make sure that the modeling menu set or a modeling workspace is selected. 

 

 

 

Primitive Models 

Primitive models are simple geometric shapes, like spheres, cubes, and cones. 

 

Polygon Primitives: 3D geometric shape meshes formed by patches of 2D triangular or 
polygonal shapes. Create them by going to (Main Menu) Create > Polygon Primitives. 

NURBS Primitives: 2D and 3D geometric shapes formed by curves drawn in space. Create them 
by going to (Main Menu) Create > NURBS Primitives. 

 
Extruded Models 

Extruded Text is created by going to (Main Menu) Create > Type 
and editing the type properties in the Attribute Editor.  

 

Extruded Shapes can be created from closed 2D shape curves. 

1. Go to (Main Menu) Create > Curve Tools and select one of the tools. 
2. Draw a curve. Working in an orthogonal view (top, front, side) will be easier. 
3. Shift-Right Click the curve and go to Close Curve or go to (Main Menu) Curves > Open/Close 
4. Go to (Main Menu) Surfaces > Bevel 
5. Open the Attribute Editor 
6. Edit the bevel Width, Depth, Extrusion Depth, Tolerance, Corner Type, Bevel Shape 
7. Go to (Main Menu) Curves > Reverse Direction to turn the shape inside out 

 



 

Revolved Models 

 Revolved Shapes can be created from open shape curves 

1. Go to (Main Menu) Create > Curve Tools and select one of the tools. 
2. Draw a curve. Working in the front view is recommended. 
3. Make sure the curve is not closed and does not cross the Y-axis (vertical axis). 
4. Go to (Main Menu) Surfaces > Revolve 
5. Go to (Main Menu) Curves > Reverse Direction to turn the shape inside out 

 
Reversing Normals 

Normals are imaginary lines perpendicular to the surface faces. Normally, they point away from 
the object, so that materials and textures like fur will be applied to the outside of the surface. 

However, if the normal are pointing the wrong dimensions, materials and textures will be 
applied to the inside of the surface and not be seen. Maya has commands to reverse the normal 
and fix the problem for curves, meshes, furs, and other surfaces. 

 

 

 

Challenge #1 – Working with Menus and Models 

1. Change to the Modeling Menu Set. 
2. Create a sphere by going to (Main Menu) Create > Polygon Primitives > Sphere 
3. Create a torus by going to (Main Menu) Create > Polygon Primitives > Torus 
4. Shift-click both shapes to select them both 
5. Combine the shapes by going to (Main Menu) Mesh > Combine 
6. Tap the F key to see a closeup of selected object in your selected view. 

 
 
  



Outliner Panel 
  

Open by going to (Main Menu) Windows > Outliner (see all objects, cameras, lights, etc.) 

Or click the Outliner Button  below the Quick Layout Buttons. 
 

 
 

 

Tool Box 
 

The Tool Box contains tools that you use 
all the time to select and transform 
objects in your scene. Use the QWERTY 
hotkeys to use the Select tool (Q), Move 
tool (W), Rotate tool (E), Scale tool (R), 
and Show Manipulators (T), as well as 
access the last tool used (Y) in the scene. 

 
A 3-axis overlay appears over the object 
when transform tools are selected. 
Click and drag the middle yellow square 
handle to transform in any axis. 
Click and drag a colored arrow to 
constrain the transformation in that 
direction. 

 
 

  

1. Outliner Menus 

2. Outliner Layer Filter 

3. Outliner Search Box 

4. Groups and Hierarchies of Nodes 

5. Materials 

 



 
 

Object Selection Mode 
 
Right-click the object and drag to the Object Mode option in the marking menu. 
You can now click to select the entire object. The wireframe will turn green. 

 
 
Component Selection Mode 
 

The component selection mode makes a hard selection. It could be used to extrude one 
subdivided patch of a polygon object. 
 
Right-click the object and drag to select a component type such as Vertex, Edge, or Face. 
You can now use the selection tools to select parts of your object.  The wireframe will turn blue. 
 
You can extrude a selected polygon face, edge, or vertex by Shift + dragging the Move, Rotate, 
or Scale tool, or by pressing Ctrl-E, or by going to (Main Menu) Edit Mesh > Extrude. 
 
Shift-Left-click adds to a component selection, Ctrl-Left-click removes from selection 
Note that the Paint Selection Tool automatically switches to component mode 
Right-click and hold to switch back to object mode (choose Object Mode) 
 
 

Soft selection Mode 
 

The soft selection mode works more like clay, allowing you to push and pull parts of an object. 
 
1. Go to component mode by selecting a component type such as vertex, edge, or face. 
2. Tap the ‘b’ key on your keyboard to switch to soft selection mode. 
3. Click and hold the ‘b’ key while dragging to affect how much of the object will be affected. 
 
You can now use the selection tools to select parts of the object. The wireframe will be colored. 
 

 



 
 
View Panel Toolbar 

 
The View Panel Toolbar above each view has cube and sphere icons for changing the preview. 
 

 
 

Select wireframe , shaded , or wireframe on shaded  buttons to change how objects 
are previewed in each view panel. 
 
 

Important: Press the textured  button after you add materials to see them in the view. 

 

Important: Press the use all lights  button to see the effect of the custom lights in the view. 

 
You can also press 1, 2, and 3 on your keyboard to turn smoothing preview on and off. This will 
show what the model will look like after applying the mesh smooth function in Maya. 
 

• Press 1 to turn off smoothing preview 
• Press 2 to turn on smoothing preview for the object only. 
• Press 3 to turn on smoothing preview for both the object and wireframe. 

 
 
Attribute Editor 

 
There are multiple ways to open the Attribute Editor. 
In the Classic Workspace, click the Attribute Editor tab on the very right side of the screen. 
The Modeling - Standard Workspace will show the Attribute Editor by default. 
Go to (Main Menu) Windows > General Editors > Attribute Editor 
 
Tabs at the top of the Attribute Editor allow you to access the nodes of your selected object. 
 

 



Challenge #2 – Working with Attribute Editor 

1. Open the attribute editor using one of the methods above. 
 

2. Select your grouped object in the View Panel or the Outliner. 
 

3. At the top of an editor is a field labeled “transform.” Change the value to “UFO” 
 

4. Click on the 7 tabs to view the different nodes associated with the object group. 
 
a. UFO is the new node name for the transformation properties of the grouped object. 
b. UFOShape contains mesh properties for the group object’s shape. 
c. polyUnite1 is the node generated by the Mesh > Combine command. 
d. polyTorus1 is the underlying donut shape, with controls for the radius and subdivisions. 
e. polySphere1 is the underlining sphere shape, with controls for radius and subdivisions. 
f. initialShadingGroup  contains a default surface so the shape can be seen and rendered. 
g. lambert1 is the default shader associated with the initial shading group. 

 
5. Experiment with changing the transform properties in the UFO node. Note you can change 

position, rotation, and scale values numerically here instead of using the Tool Box buttons. 
 

6. Experient with changing the radius values in the polyTorus1 and polySphere1 nodes. Note 
the subdivision sliders, which you often need to move before using many mesh commands. 

 
 
Hypergraph Connections Panel 
 
 To open this panel, go to (Main Menu) Windows > General Editor > Hypergraph Connections 
 
 This view will show all the nodes that make up a selected object, and how they are connected. 
 
 Note: Click on a node in they hypergraph panel to open the node in the Attribute Editor. 
 
 Note: Delete nodes in the hypergraph panel by clicking them and pressing the delete key. 
 

 
 
 



Surfacing 
 
Materials Editor 
 

In Maya, the appearance of a surface is defined by how it’s shaded. Surface shading is a 
combination of the basic material of an object and any textures that are applied to it.  
Materials (also called shaders) define an object’s substance. Some of the most basic attributes 
of materials include color, transparency, and shine.  

Important: Press the textured  button in the Panel View to see your materials in the view. 

Select an object (or a part using components!), right-click, and choose Assign New Material… 
 

  
 

 

After adding the Phong shader to 
an object, the shader node will 
appear in the attribute editor. 
Common attributes you can change 
using the sliders and color picker 
boxes include: 

• Surface Color 
• Object Transparency 
• Incandescence (Glow) 
• Diffusion vs Reflectivity 
• Object Translucence 
• Specular Highlights 

The left side of the materials selector window 
shows the category of available shaders.  

Important: You must select shaders compatible 
with your scene’s render settings. Arnold Shaders 
will not work with the Maya Software Renderer. 

Maya’s used the Lambert shader as the default 
shader for newly created objects. This is a basic 
shader with minimal attributes. 

A common choice you will make for your object 
materials is the Phong shader. Phong gives access 
to additional properties like specular highlights, 
the shiny highlights that appear on the curves of 
reflective substances. 

 



 
Texture Maps 

Factors beyond basic color, transparency, and shine that determine the appearance of an 
object’s surface (such as more complex color, transparency, shine, surface relief, reflection, or 
atmosphere) are defined by textures. 

Examples of texture types include: 

•   Procedural Maps 
Procedural texture maps are created using a mathematical algorithm 
instead of stored pixel data. They are often used for representing 
natural materials like mood, metal, and stone. (Image from Wikipedia) 

   
•   Image Maps 
Bitmap (raster) images contain pixel data which is wrapped 
around the model. (Image from planetpixelemporium.com) 
 

 
Materials and Textures in the Attribute Editor 

If you clicked away and can’t find the material in the attribute editor, select the object in the 
View Panel or Outliner. Browse the tabs in the attribute editor until you see the shader’s name. 

    

 

Using Procedural Maps in Maya 

In the Attribute Editor shader node, click the  map button next to the attribute you want to 
connect a texture (like color or bump mapping). The Create Render Node window appears. 

 

Select Checker in a Create Render Node for the Color 
attribute to add a checkerboard procedural map to the 
object. 

Select Bulge in a Create Render Node for the Bump Mapping 
attribute to apply a pattern of raised bulges to the object.  

 



Using Image Maps in Maya 

In the material Attribute Editor, click the  map button beside the attributes that you want to 
apply an image map to (like color or bump mapping). The Create Render Node window appears. 

 

 

 
 

 

 
 
 
Back in the attribute editor for the shader, note that the map icon on the right has changed to a 
dark gray arrow pointing to the right. Clicking this texture node connection icon will bring you 
back to the texture map node: 

 

In the file node, File Attributes 
section, select a file into the 
Image Name field by clicking 
the yellow folder icon. 
 
Remember your image maps 
should be stored in the 
project’s Source Images folder.  
 
Also note an animation can be 
selected using the Image 
Sequence option. 
 

In the place2dtexture node, you can 
reposition how the image wraps around the 
object. 
 
Coverage values scale the image map. Use 
less than 1 to shrink the image map, greater 
than 1 to stretch the image map. 
 
For NURBS – you also must uncheck Wrap U 
and Wrap V for coverage to work. 
 

Select File in a Create Render Node for the Color 
attribute to add an image map to the object. 

Select File in a Create Render Node for the Bump 
Mapping attribute to add an image map to provide 
raised texture on the object. 

 



Challenge #3 – Working with Materials 

1. Download the earth color map and bump map from planetpixelemporium.com/earth.html 
2. Move the images to your project’s Source Images folder. 
3. Change to the Modeling Menu Set. 
4. Create a sphere by going to (Main Menu) Create > Polygon Primitives > Sphere. 
5. Right Click the object to assign a new material and choose the Lambert shader. 
6. Click the map button next to the Color property and choose to add a File node. 
7. Select the earth color map in the file field. 
8. Return to the Lambert shader node.  
9. Click the map button next to the Bump Mapping 

property, and choose to add a File node. 
10. Select the earth bump map in the file field. 

 
 

 
 
 

 
Hypershade Panel 

 To open this panel, go to (Main Menu) Windows > Rendering Editors > Hypershade 
 
 This view will show all the nodes that make up a selected object, and how they are connected. 

 Note: Click on a node in they hypergraph panel to open the node in the Attribute Editor. 
 
 Note: Delete nodes in the hypergraph panel by clicking them and pressing the delete key. 
 

  



 

Animation 
 
Animation Menu Set 

Many of the menu options used for animation are only available when the 
Animation Menu Set is chosen. If any of the features below seem unavailable, 
make sure that the animation menu set or animation workspace is selected. 

 

  
 
Channel Box 
 

There are multiple ways to open the Channel Box panel.  
In the Classic Workspace, click the Channel Box tab on the very right side of the screen. 
The Animation Workspace will show the Channel Box by default. 
Go to (Main Menu) Windows > General Editors > Channel Box Editor 

 
The Channel Box is a panel that shows keyframable properties of 
the selected object. This is a subset of the full set of properties in 
the attribute editor, not all of which can be keyframed. 
 
The top section allows gives you access to the main transform 
properties of the object. 
 
The Input and Output sections below give you access to keyframable 
properties of the connected nodes. 
 
 

Animation Controls 
 

The Animation Controls are shown at the bottom of the classic and animation workspaces. 
 
The Time Slider is a bar you can use to scrub through your animation. 
 
Playback Controls are used to preview your animation. The shortcut is Alt/Opt – V. 
 
 

 
 

  



The Range Slider controls the playback range and the animation start / end time. 
 
Enter new values in the A and E boxes below to change the number of frames in your animation. 
 

 
 
A. Animation Start Time B. Playback Start Time C. Range Slider Bar D. Playback End Time 
E. Animation End Time F. Character Set Menu G. Animation Layer menu 
 
 
In the Playback Options, you can set the frame rate. 
 

Click the Animation Preferences button  in Playback Options to access the Time Slider 
dialog box. In the Playback section you can choose to either play every frame as quickly as 
possible or force the playback to run at your chosen frame rate. 
 

Tip: You can use the Auto Key button to automatically set a key every time you adjust the 
time on the Time Slider and move the object. 

 
 
Keyframe Animation 
 

To set keys: 
 
1. Select the object with the attributes you want to key. 
2. Drag the time slider to the frame you want the animation to start. 
3. Press the ‘S’ key on your keyboard. 
4. The current properties at the selected time will be stored in the keyframe. 
 
To complete the tween animation: 
 
1. Drag the time slider to the frame you want the animation to end. 
2. Change the attribute values. 
3. If you selected Auto Key, a new keyframe is automatically created. Otherwise press ‘S’ again. 
4. The keyframe animation is now complete. 

 
 
Lights 

 

Important: Press the use all lights  button in the Panel View to see the effect of your lights. 

To create a spotlight: 
 
1. Go to (Main Menu) Create > Lights > Spot Light 
2. In the orthogonal views, move and rotate the light to aim at your subject. 
3. You need to aim your object at the light in 2 of the 3 orthogonal views 
4. In the Attribute Editor light node, change the color, intensity, cone angle, and dropoff. 
5. Try animating your lights. 

 



 
Camera 
 
 To create a camera: 
 

1. Go to  (Main Menu) Create > Cameras > Camera 
2. The Camera and Aim option creates a point you can move or parent to a subject. 
3. If you don’t use Camera and Aim, move and aim the camera at your subject. 
4. Make sure the lights are near the camera for your subject to be visible. 
5. From the perspective view’s Panel Menu, change Perspective from “persp” to your camera. 
6. Try animating your cameras. 
 

 
Nonlinear Deformers 
 

To animate a deformation: 
 
First select the object’s source shape, and make sure there are enough subdivisions to deform 
the shape along your desired axis. 
 
1. Go to (Main Menu) Deform > Nonlinear 
2. Open the bend input in the Attribute Editor or Channel Box. 
3. Try changing properties like the curvature value to get the deformation effect. 
4. The nonlinear deforms can be used for modeling, but can also be keyframed for animation. 
 

  
 
 

Challenge #4 – Working with Animation 

1. Create an animation that rotates the planet Earth created in the previous challenge. 



Rendering 
 

Rendering Menu Set 

Many of the menu options used for rendering are only available when the 
Rendering Menu Set is chosen. If any of the features below seem unavailable, 
make sure that the rendering menu set or rendering workspace is selected. 

 

 
Maya Renderers 
 
 Maya provides several different rendering options, including: 
 

• Maya Software 
• Maya Hardware (much faster, if you have high compatible computer hardware) 
• Arnold (photorealistic renderer that may require use of Arnold materials and lights) 

 
 
Maya Software Renderer 
 

Steps to render an animation with the software renderer:  
 
1. (Main Menu) Window > Rendering Editors >  

Render Settings 
 

2. Choose Maya Software as your renderer. 
 

3. Change the Image Format to TIFF. 
 

4. Change Frame/Animation extension to name#.ext 
 

5. Choose the frame range to render. 
 

6. Select the Renderable Camera. 
(persp for the default, or your own custom camera) 
 

7. Make sure Alpha Channel is checked. 
 

8. Choose an image size preset. 
 

9. In the Maya Software tab, choose quality settings. 
 

10. In the Maya Software tab, Color/Compositing Section,  
note if Premultiply is selected. 
 

11. Go to (Main Menu) Render > Batch Render 
 

Your images will be saved to your project’s Images folder. 
 



Compositing 
 
Compositing in Maya 
 
 Sometimes, simple compositing tasks are completed right in the 3D program. 
 

A skybox is an image map placed on the inside of a large sphere wrapped around your scene. 
The technique can be used to create the sky for an outdoor scene. 
 
An image plane in Maya is an image map attached to a view’s background. The technique can 
be used to create a starfield behind a space animation. 

 
Maya Image Planes 
 

From each view's menu, go to View > Image Plane > Import Image or Movie 
 
Go to (View Menu) View > Image Plane > Image Plane Attributes to change properties 

In the Attribute Editor is an Image Plane Attribute section for editing color, offset, alpha 
   Below the color properties is placement: resize, position image within view 
    At bottom are extra attributes, like Locked to Camera 

• When checked, fixes position of image in the background 
• When unchecked, locks image to grid origin and moves as you move the 

view/camera 
 

If Image Plane selection is lost go back to (View Menu) View > Image Plane 
Image Planes can be deleted using the delete key when selected 

 
Compositing in After Effects 

 
1. Create a new After Effects composition 
2. Enter the resolution and frame rate to match your animation 
3. From File > Import, make sure the Sequence checkbox is checked, and import as Footage 
4. Make sure Alpha settings (Straight or Premultiplied) match Maya's setting (press Guess) 

 
Use the footage clip like any our source file in a composition layer 
All filters, transformations, and effects can be used on your animation footage layer 
Place other images or videos behind your animation, the alpha channel will let it show through. 

 
After Effects Live Link 

 
You can go to (Main Menu) File > Adobe After Effects Live Link 
This will import camera data so you can sync your camera movements with After Effects 
 
 
 

Challenge #5 – Working with Rendering and Compositing 

1. Complete a batch render of your Earth animation. 
2. Composite your Earth animation with a starfield graphic. 



FX (Effects) 
 
Particle Systems 
 

Make sure you open the FX menu set. 
 
A Particle System is a physics simulator that can create rain, snow, fire, explosions, and many 
other effects. 
 
 

Challenge #6 – Working with Particle Systems 

1. From the FX menu set, go to (Main Menu) nParticles > Create Emitter 
2. Move the emitter up in the front view. 
3. Choose nParticle1 from Outline Window in Attribute window. 
4. In nParticleShape1 node, Shading section, change Particle Render Type to Spheres. 
5. Also, scroll down and select a Color. 
6. Create a plane object 
7. To make them collide, shift select the particles first and the plane second 
8. Go to (Main Menu) nParticles > Make Collide when they are both selected together 
9. Select the plane 
10. Go to (Main Menu) nCloth > Create Passive Collider 
11. Select nParticle1 
12. Go to (Main Menu) Fields > Vortex 
13. Increase the vortex magnitude so the spheres spin off the plane. 
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